UK Audi Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all, I'm having a problem with my audi a4 2007 as stated in the title. The car feels like it's pulling back and kicks out a lot of smoke. It starts up fine and idles OK however when it hits 2000rpm the engine doesn't want to go any further and without dipping the clutch it really struggles to get going. The turbo seems to be kicking in late also around 3000rpm instead of the normal 2000rpm. This started as I was travelling home and I continued to drive around another 10 miles to get there, just as I pulled up that's when the glow plug light started flashing.

I have taken the car to a few different garages now and they want no part in finding the problem as the car has the egr deleted, dpf removed and has been remapped (all things I wasn't aware of). It has however thrown up some fault codes and I'm hoping that someone on here might have an idea what's best to start with.

I'm pretty clueless about the inner workings of cars, I just drive them so all help would be greatly appreciated as Ive only had this car for just over a year.

These are the codes:

P0299-006-Control Range Not Reached - Intermittent
Freeze Frame:
Fault Status: 00000001
Fault Priority: 5
Fault Frequency: 1
Reset Counter: 40
Mileage: 0 km
Time indication: 0

Freeze Frame:
RPM: 2144 /min
Torque: 240.0 Nm
Speed: 71 km/h
70.20%
Voltage: 13.90 V
Pressure: 2364.3 mbar
Pressure: 1512.3 mbar

000257 - Mass Air Flow Sensor (G70)
P0101-006-Implausible Signal-Intermittent
Freeze Frame:
Fault status: 00000001
Fault Priority: 1
Fault Frequency: 1
Reset Counter: 40
Mileage: 0 km
Time Indication: 0

Freeze Frame:
RPM: 2272 /min
Torque: 0.0 Nm
Speed: 100 km/h
Temperature: 11.0°C
Pressure 1214.1 mbar
Text: 100 kg/h
(no units): 1.58

Thanks in advance to any suggestions with where to look or what to start with.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top